Degraded Performance - ProMetrix Web

Incident Report for Verisk Insurance Solutions - ISO

Resolved

Please be advised some clients may have experienced degraded performance from 09/09/26 at 1:16 PM ET to 09/10/26 at 12:46 PM ET.
Posted Sep 10, 2026 - 13:24 EDT

Investigating

Please be advised we are investigating degraded performance for ProMetrix web. We will provide updates as this is investigated.
Posted Sep 10, 2026 - 12:31 EDT
This incident affected: ProMetrix Website (Address Search, APLUS Commercial, Billing, Building Characteristics Report, Building Fundamentals, Building Overview Report, Building Underwriting Report, Casualty Underwriting Report, Casualty Underwriting Advantage Report, CL VIN Decode Report, Diagram, Estimated Loss Cost Report, InfoGroup Business Report, LOCATION Auto Territories, LOCATION BCEGS, LOCATION Crime, LOCATION Fireline, LOCATION Flood Assist, LOCATION Future Effective PPC, LOCATION PPC, LOCATION Premium Tax, LOCATION Wind, Loss Cost Report, Loss Estimate Report, Order Survey, Peril Report, Property Details Report, Rating Survey Details, Replacement Cost Report, Risk Engineering Utility, Risk Improvement Statements, Roof Underwriting Report, Small Commercial Underwriting Report, Short Building Underwriting Report, Short Rating Survey Details, Sign up, Sprinkler Assessment Report, Underwriters Advantage Report, Waterline Report).