IT Service Issue - Lloyds Wording Repository

Incident Report for Verisk Insurance Solutions - ISO

Resolved

Please be advised Lloyds Wording Repository experienced a service issue that began at 11:14 AM ET, with services restored at 11:54 AM ET. We thank you for your patience and apologize for any inconvenience this issue may have caused.
Posted Mar 24, 2026 - 13:02 EDT

Investigating

Please be advised Lloyds Wording Repository is currently experiencing a service issue. Verisk staff are working to resolve this issue as quickly as possible. We thank you for your patience and we will provide updates as the issue is resolved.
Posted Mar 24, 2026 - 11:51 EDT
This incident affected: Rating API United Kingdom (Lloyds Wording Repository).