IT Service Issue - BuildFax

Incident Report for Verisk Insurance Solutions - ISO

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 17:39 EDT

Update

Please be advised upon further investigation it has been determined that the Data Access Portal is operational and this is only impacting www.buildfax.com.
Posted Mar 30, 2026 - 17:38 EDT

Investigating

Please be advised BuildFax is currently experiencing a service issue. Verisk staff are working to resolve this issue as quickly as possible.
Posted Mar 30, 2026 - 17:29 EDT