Degraded Performance - Motor Vehicle Reports

Incident Report for Verisk Insurance Solutions - ISO

Resolved

We had a momentary slowdown with reports for a number of states, but everything is processing now and reports are returning usual.
Posted Jun 04, 2025 - 15:47 EDT

Investigating

Please be advised we are investigating a possible degraded performance issue impacting Motor Vehicle Reports for several states. We will provide updates as we investigate this issue.
Posted Jun 04, 2025 - 15:37 EDT
This incident affected: Passport Website (Motor Vehicle Reports), Passport API (Motor Vehicle Reports), and Underwriting API (Motor Vehicle Report).